Admin connection failed

Home Forums Pie-Register 2.0 Support Admin connection failed

This topic contains 15 replies, has 4 voices, and was last updated by  Hasnain Abbas 2 years, 10 months ago.

Viewing 10 posts - 1 through 10 (of 16 total)
  • Author
    Posts
  • #4236

    freddela
    Participant

    I have a critical problem . When I log in as an administrator with the login form of PR , the connection fails because of a redirect loop. The navigator try to open the admin page (https://copperprodev.coppernic.fr/wp-admin) without success.

    redirect

    In the Frontend Settings/Redirect Logged-in Users, I have tried NO instead of YES. Now , I stay on the login form page but I can’t go to my back office !!

    settings

    When I log in as a subscriber, everything is ok.

    #4239

    Hasnain Abbas
    Keymaster

    Hello,

    We apologize for the inconvenience this may occurred to you. The “Redirect Logged In Users” option is only to make PR pages accessible by a logged in users or not. It doesn’t affect on “Redirection on Login”. However, can you please try to login on a different browser or clear out your cookies to see if it working again? Also please let us know the PR and WP versions?

    Thanks

    #4242

    freddela
    Participant

    Hello,

    I tried with different browsers (chrome, firefox , IE, safari…), I deleted caches, cookies, disable others plugins and It does not change anything.

    Version WordPress : 4.3.1
    Version PR : 2.0.20 (But now I had to install the previous version 2.0.17)

    #4245

    Hasnain Abbas
    Keymaster

    Hello,

    Do you have SSL enabled on your site and for wordpress login?

    #4246

    freddela
    Participant

    As you can see in the adress bar (https://copperprodev.coppernic.fr/), the website use the https protocol for security reasons.

    #4250

    Hasnain Abbas
    Keymaster

    Thanks for the update, I will have team lookup the issue and we will get back to you asap.

    Thanks

    #4252

    freddela
    Participant

    thank you very much

    #4265

    freddela
    Participant

    Hello,
    Have you found a solution to my problem ?
    Thanks

    #4266

    cwjordan
    Participant

    I am seeing the same symptoms as freddela when I try to upgrade from version 2.0.17 to 2.0.20 (in a development environment). I have briefly tried 2.0.18 and 2.0.19 and could not reproduce the problem there, so I amy upgrade to 2.0.19 instead for now. I do have “define(‘FORCE_SSL_ADMIN’, true);” set in my wp-config.php file, but removing that doesn’t fix the problem.

    #4267

    cwjordan
    Participant

    In fact, if I change line 945 of pie-register.php in version 2.0.20 from:

    `wp_set_auth_cookie( $user->ID, $creds[‘remember’], $piereg_secure_cookie );
    `

    to

    wp_set_auth_cookie( $user->ID, $creds['remember'] );

    then I can log in and go to the admin page okay, without the redirect problem. So does appear to be something with SSL.

Viewing 10 posts - 1 through 10 (of 16 total)

You must be logged in to reply to this topic.