Logout URL not working - Pie Register
2018-12-11 08:31:01

Logout URL not working

Home Forums Pie-Register 2.0 Support Logout URL not working

Tagged: 

This topic contains 6 replies, has 3 voices, and was last updated by  Mattia Spadolini 3 years, 4 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #3119

    Twix Chopra
    Participant

    Hi,

    I am appending ?piereg_logout_url=true to my logout link. It was working when I tested yesterday. But today when I checked it again, it is not working.

    After clicking on to the logout URL, it not getting logged out and in the URL, It is showing example.com/??piereg_logout_url=true.

    NOTE: I have not given any redirect page url and I have not changed any setting from the back end of pie register.

    Thanks.

    • This topic was modified 3 years, 10 months ago by  Twix Chopra.
    #3121

    Twix Chopra
    Participant

    Sorry there is typo …

    It is example.com/?piereg_logout_url=true in the URL.

    What might be the issue ?

    #3126

    Pie Register
    Keymaster

    Hello,

    Please remove additional “?” into the URL. So there would be only one “?”.

    Thanks

    #3128

    Pie Register
    Keymaster

    Ok so what do you see when you locate this link on your browser? Also please make sure you are appending this variable on your wordpress home or interior pages url.

    Thanks

    #3802

    Mattia Spadolini
    Participant

    Hello folks.

    Same problem here.
    Added custom link with the code above, but log out seems not working, the session is still alive, and the login cookies still there.

    any suggestion?

    #3804

    Pie Register
    Keymaster

    Just tested on
    https://pieregister.com/forums/topic/logout-url-not-working/?piereg_logout_url=true&redirect_to=http%3A%2F%2Fpieregister.genetechsolutions.com%2Fforums%2Ftopic%2Flogout-url-not-working%2F

    It looks like its working fine for us, please make sure:
    1.) You have blocked wp-login pages
    2.) providing redirect_to URL value

    Thanks

    #3805

    Mattia Spadolini
    Participant

    Redirect-to was the problem, thanks!

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.