Logout URL not working

This topic contains 6 replies, has 3 voices, and was last updated by Avatar Mattia Spadolini 4 years, 2 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #10003119
    Avatar
    Twix Chopra
    Participant

    Hi,

    I am appending ?piereg_logout_url=true to my logout link. It was working when I tested yesterday. But today when I checked it again, it is not working.

    After clicking on to the logout URL, it not getting logged out and in the URL, It is showing example.com/??piereg_logout_url=true.

    NOTE: I have not given any redirect page url and I have not changed any setting from the back end of pie register.

    Thanks.

    #10003121
    Avatar
    Twix Chopra
    Participant

    Sorry there is typo …

    It is example.com/?piereg_logout_url=true in the URL.

    What might be the issue ?

    #10003126
    Avatar
    Pie Register
    Participant

    Hello,

    Please remove additional “?” into the URL. So there would be only one “?”.

    Thanks

    #10003128
    Avatar
    Pie Register
    Participant

    Ok so what do you see when you locate this link on your browser? Also please make sure you are appending this variable on your wordpress home or interior pages url.

    Thanks

    #10003802
    Avatar
    Mattia Spadolini
    Participant

    Hello folks.

    Same problem here.
    Added custom link with the code above, but log out seems not working, the session is still alive, and the login cookies still there.

    any suggestion?

    #10003804
    Avatar
    Pie Register
    Participant

    Just tested on
    https://pieregister.com/forums/topic/logout-url-not-working/?piereg_logout_url=true&redirect_to=http%3A%2F%2Fpieregister.genetechsolutions.com%2Fforums%2Ftopic%2Flogout-url-not-working%2F

    It looks like its working fine for us, please make sure:
    1.) You have blocked wp-login pages
    2.) providing redirect_to URL value

    Thanks

    #10003805
    Avatar
    Mattia Spadolini
    Participant

    Redirect-to was the problem, thanks!

Viewing 7 posts - 1 through 7 (of 7 total)

The forum ‘Pie-Register 2.0 Support’ is closed to new topics and replies.