Email Verification Error

Home Forums Installation Email Verification Error

This topic contains 11 replies, has 3 voices, and was last updated by  PIE REGISTER 3 years, 9 months ago.

Viewing 10 posts - 1 through 10 (of 12 total)
  • Author
    Posts
  • #2832

    Kevin Reynolds
    Participant

    Hi

    I have the email verification enabled, but when i click the link in the email it says ‘Warning: You are already activate’, and i can also log in regardless of whether i click the link in the email or not

    Is there a setting of wordpress that is overriding the need to email verification before an account is active?

    Thanks
    Kevin

    #2837

    PIE REGISTER
    Keymaster

    Hi,

    Can you please try disabling the Email verification and then re-enable
    it to see if it fix?

    Thanks

    #2855

    Kevin Reynolds
    Participant

    hi thanks for your reply

    That didnt work – the email comes through but it still lets me in regardless, and clicking the link in the email gives an error that iam am already activated

    #2899

    Kevin Reynolds
    Participant

    Hi – still waiting on a response for this!

    #2931

    PIE REGISTER
    Keymaster

    Hello,

    If you still have this issue exist after upgrading to the latest version, I would suggest you to send us login information using contact form at our Website.

    Thanks

    #3014

    Marc
    Participant

    I am sorry but I got the exact same problem. Fresh install. E-Mail notification enabled. What do I have to set up under WordPress->Settings->Discussion ? Does it may be depend on that settings?

    I look in my db. The status in the usermeta table is 0 until the user clicks the link. So he is not able to login before the activation. But he gets the wrong message somehow. The DB entry is correct, tough.

    Your help is much appreciated.

    #3015

    Marc
    Participant

    The metakey “hash” seems to be empty for all new users. Is this important and what causes this?

    #3016

    Marc
    Participant

    Sorry, my mistake. The “hash” is set. Must be something else =/

    #3017

    Marc
    Participant

    Ok, more infos:

    The code gets called twice somehow. I inserted an error logging to login_form.php in Line 79. I printed the variable $unverified and this is what I got:

    [16-Jan-2015 11:53:49 UTC] Array
    (
        [0] => WP_User Object
            (
                [data] => stdClass Object
                    (
                        [ID] => 20
                        [user_login] => Marc20
                        [user_pass] => 829847928374982749827(hash removed)
                        [user_nicename] => marc20
                        [user_email] => ma.......@gmail.com
                        [user_url] => 
                        [user_registered] => 2015-01-16 11:51:56
                        [user_activation_key] => 
                        [user_status] => 0
                        [display_name] => Marc20
                    )
    
                [ID] => 20
                [caps] => Array
                    (
                        [subscriber] => 1
                    )
    
                [cap_key] => wp_capabilities
                [roles] => Array
                    (
                        [0] => subscriber
                    )
    
                [allcaps] => Array
                    (
                        [read] => 1
                        [level_0] => 1
                        [subscriber] => 1
                    )
    
                [filter] => 
            )
    
    )
    
    [16-Jan-2015 11:53:49 UTC] Array
    (
    )
    

    As you can see, the array is set at first and then the code is executed again. Any idea?

    #3018

    Marc
    Participant

    Ok, since nobody is answering my question here is more debug info:

    If I disable the widget in the sidebar of twentyfifteen (bonusinfo: sidebar is before the content area in this theme), I see no message when a user is using his link. Just nothing but he is activated. =/

Viewing 10 posts - 1 through 10 (of 12 total)

You must be logged in to reply to this topic.