Cannot edit profile

Home Forums Installation Cannot edit profile

Tagged: 

This topic contains 8 replies, has 2 voices, and was last updated by  Dolf H 3 years, 7 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #2953

    Dolf H
    Participant

    Hi,
    I installed and activated this beautiful plugin (2.0.14) with WP 4.0.1. Everything is working nice but I have an issue in “editing profile”.

    In the profile page the user sees the edit profile-icon, but the link does not work: the edit page is loading again and the fields cannot be changed, whatever user-role I choose. The url changes form http://www.example.com/edit to http://www.example.com/edit/?page_id=&edit_user=1 .
    I deactivated all plugins, changed to default theme and I tried another browser. Without result. Debug shows nothing when clicking the edit-icon. Please tell me how to solve this issue.

    #2956

    PIE REGISTER
    Keymaster

    Hello,

    This is very strange and may be limited to your own enviorment, please
    go to settings >> permalink >> save settings and try again.
    Kindly let me know if this resolve the problem.

    Thanks

    #2959

    Dolf H
    Participant

    Thank you for your answer. I saved the permalink settings again, without result.
    When I open the login screen (before loging-in) I get these debug-code:

    Strict Standards: Non-static method PieReg_Base::pie_registration_url() should not be called statically in C:\domains\grenspostadres.nl\subdomeinen\dev\wwwroot\wp-content\plugins\pie-register\pie-register.php on line 3602

    Strict Standards: Non-static method PieReg_Base::pie_lostpassword_url() should not be called statically in C:\domains\grenspostadres.nl\subdomeinen\dev\wwwroot\wp-content\plugins\pie-register\pie-register.php on line 3610

    Perhaps is this helpful?

    #2963

    PIE REGISTER
    Keymaster

    Hello,

    Thank you for your input, actually this is something else, it has
    nothing to do with profile edit link. Your profile link has page_id
    variable which is why i was doubt that your permalink is not set., Can
    you please let us know what are your permalink settings?

    Thanks

    #2965

    Dolf H
    Participant

    Hello,

    My permalink-settings are custom: http://www.example.com/%postname%/

    Thanks.

    #2969

    PIE REGISTER
    Keymaster

    One last thing before I ask you for the temporary access.
    Can you please remove the page_id variable from edit profile link?
    example:
    http://yourdomain.com/your-profile-page/?page_id=&edit_user=1
    to
    http://yourdomain.com/your-profile-page/?edit_user=1

    and see if it works.

    Also please clear your browser cache before doing so or use a different browser.

    Thanks

    #2971

    Dolf H
    Participant

    Thanks again for your reply. I cleared the cache and tried with the suggested url, but no result.
    How can I give you temperary access?

    #2973

    PIE REGISTER
    Keymaster

    Please use contact form on website to send us login details,.

    Thanks

    #3000

    Dolf H
    Participant

    Well, it works. My host is using a Windows Server/IIS, so I use a iirf.ini file instead of a .htaccess file.

    Remove the default WordPress content of the file and replace this:

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^/.*$ /index.php [L,QSA]

    Another way is to force a redirect in the settings of Pie-register to:

    http://yourdomain.com/index.php/your-profile-page instead of the normal page: http://yourdomain.com/your-profile-page.

    Your permalink-settings are:
    http://www.example.com/%postname%/

    Now you can edit the profile and index.php pops up only in the profile page, but that should not be a big issue.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.